aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-04-29 12:07:02 -0700
committerKhem Raj <raj.khem@gmail.com>2020-05-03 14:29:17 -0700
commitd188161783030fa190effec34c7dc25ea7a7171b (patch)
tree0a14a96001b86a8857802a77f793e5ece8d492e5 /meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
parentf30a3cfa9d97357d045aa8e1c0d22bb6584c2d77 (diff)
downloadmeta-openembedded-d188161783030fa190effec34c7dc25ea7a7171b.tar.gz
python3-pysocks: add python3-logging to RDEPENDS
python3-pysocks uses the logging module, but it isn't in the RDEPENDS list: root@qemux86-64:~# python3 Python 3.8.2 (default, Feb 25 2020, 10:39:28) [GCC 9.3.0] on linux Type "help", "copyright", "credits" or "license" for more information. >>> import socks Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib/python3.8/site-packages/socks.py", line 9, in <module> import logging ModuleNotFoundError: No module named 'logging' Add it to RDEPENDS to fix the ModuleNotFoundError. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
index e311904fcf..d0db8a0636 100644
--- a/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
@@ -12,6 +12,7 @@ inherit pypi setuptools3
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-email \
${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
${PYTHON_PN}-netclient \
${PYTHON_PN}-shell \
"