aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 17:25:57 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commitf9b8affe0e23cb541a89cd3764a5a70a31298e5d (patch)
treeda2f265681bf84cf2fbc390efb9b8c72a8f48b22 /meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
parent9d4a0b8bfcbf9be6d5a1a9ca92b633aa1d4347aa (diff)
downloadmeta-openembedded-f9b8affe0e23cb541a89cd3764a5a70a31298e5d.tar.gz
python-pytest-asyncio: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
index 09f26f8d15..a7e963b044 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
@@ -1,2 +1,13 @@
-inherit setuptools3
-require python-pytest-asyncio.inc
+DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881"
+
+SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf"
+SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"