aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-22 13:35:37 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:55:33 -0700
commit3c65b67d225c35338306cd7b22ecf3b9f8f70973 (patch)
treea5f58fb09a2c7f5ba8fef0523cbbb519afb712d7 /meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
parent22ca2fba029e4b4568521632f3a879a4eb6a5963 (diff)
downloadmeta-openembedded-3c65b67d225c35338306cd7b22ecf3b9f8f70973.tar.gz
python3-requests-file: Upgrade 1.4.3 -> 1.5.1
Upgrade to release 1.5.1: - Add set_content_length flag to disable on demand setting Content-Length - Fix python 2.7 compatibility - Rename test file for pytest - Add tests via github actions - Format code with black Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb b/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
new file mode 100644
index 0000000000..1c8bba40dd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "File transport adapter for Requests"
+HOMEPAGE = "http://github.com/dashea/requests-file"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9cc728d6087e43796227b0a31422de6b"
+
+SRC_URI[md5sum] = "c96daf6b0c56687556e8a52748fd896c"
+SRC_URI[sha256sum] = "07d74208d3389d01c38ab89ef403af0cfec63957d53a0081d8eca738d0247d8e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ python3-requests \
+"
+