aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-07-17 03:43:16 +0800
committerKhem Raj <raj.khem@gmail.com>2020-07-16 12:10:25 -0700
commitab11bdfe0513579098553f8dd9569f8a6b39850a (patch)
tree0004b02669e604f1dcdc20df6030e36a2a021be3 /meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
parent32f5b2b03dd35885d036fa3f68eec1c4a7fd9c90 (diff)
downloadmeta-openembedded-ab11bdfe0513579098553f8dd9569f8a6b39850a.tar.gz
python3-requests-file: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb b/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
index 1c8bba40dd..88915b8fb4 100644
--- a/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-requests-file_1.5.1.bb
@@ -6,7 +6,20 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=9cc728d6087e43796227b0a31422de6b"
SRC_URI[md5sum] = "c96daf6b0c56687556e8a52748fd896c"
SRC_URI[sha256sum] = "07d74208d3389d01c38ab89ef403af0cfec63957d53a0081d8eca738d0247d8e"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
RDEPENDS_${PN} += " \
python3-requests \