aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-13 16:23:31 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-14 07:25:05 -0700
commitb5fb8390df11253fc7b20cd7a31db136f1d19a5c (patch)
treee7e0e8b0711bcfd1596931c6158da6eb7c5ec4a0 /meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb
parentbb2757ba26cbd1bf7be201a502bcfd33e2de977a (diff)
downloadmeta-openembedded-b5fb8390df11253fc7b20cd7a31db136f1d19a5c.tar.gz
python3-rfc3339-validator: Upgrade 0.1.3 -> 0.1.4
Upgrade to release 0.1.4: - Fix test failure on darwin Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb
new file mode 100644
index 0000000000..f1064f327d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A pure python RFC3339 validator"
+HOMEPAGE = "https://github.com/naimetti/rfc3339-validator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:"
+
+SRC_URI[sha256sum] = "138a2abdf93304ad60530167e51d2dfb9549521a836871b88d7f4695d0022f6b"
+
+PYPI_PACKAGE = "rfc3339_validator"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"