aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-24 11:18:13 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-25 08:15:33 -0700
commit8147981b47378ff0e669e776b64f78be6b2a6e4d (patch)
treeeb16985ea7a58d9fc3cb3d3677f3654b642df557 /meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb
parent9595fb5deec730317b209844ad418646a4f60ca7 (diff)
downloadmeta-openembedded-8147981b47378ff0e669e776b64f78be6b2a6e4d.tar.gz
python3-ruamel-yaml: Upgrade 0.17.11 -> 0.17.13
Upgrade to release 0.17.13: - minor fix in attr handling - fix issue with anchor on registered class not preserved and those classes using package attrs with @attr.s() Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb
new file mode 100644
index 0000000000..d28e8a12fe
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.13.bb
@@ -0,0 +1,21 @@
+SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
+AUTHOR = "Anthon van der Neut"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa0a51dfb461e2f803969e0f3fa71dfe"
+
+PYPI_PACKAGE = "ruamel.yaml"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "02f0ed93e98ea32498d25a2952635bbd9fabd553599b8ad67724b4ac88dd8f6c"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-shell \
+"
+
+do_install:prepend() {
+ export RUAMEL_NO_PIP_INSTALL_CHECK=1
+}
+
+BBCLASSEXTEND = "native nativesdk"