aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-07-01 14:37:01 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-06 09:40:42 -0700
commit2c08d7b8c30f0e7a69b50e3dc1227dacb325a2fe (patch)
treef64e86f39165568c7a0fbc8340d25e28ef80d280 /meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
parentcd7f0da04d730c2d6e052d92470a56111e1be5a3 (diff)
downloadmeta-openembedded-2c08d7b8c30f0e7a69b50e3dc1227dacb325a2fe.tar.gz
python3-scrypt: upgrade 0.8.17 -> 0.8.18
0.8.18 add wheel for python 3.9 and Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
new file mode 100644
index 0000000000..da3130016a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.18.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Bindings for the scrypt key derivation function library"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ddf47d0ff1849bce3257ccbc1fd275c"
+HOMEPAGE="https://github.com/holgern/py-scrypt"
+
+SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
+
+SRC_URI[sha256sum] = "bcf04257af12e6d52974d177a7b08e314b66f350a73f9b6f7b232d69a6a1e041"
+
+inherit pypi ptest setuptools3 dos2unix
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
+}