aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-08-26 10:58:07 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-30 08:10:12 -0700
commitfca75f3cc9c65910106be4ea0b6b83d1f132c9e5 (patch)
tree5c192b98321bedf5a122f1496fa002a4d65e08c7 /meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb
parent741f571615fad7bc0bfe15aef51e73292000c1c5 (diff)
downloadmeta-openembedded-fca75f3cc9c65910106be4ea0b6b83d1f132c9e5.tar.gz
python3-sqlalchemy: upgrade 1.4.22 -> 1.4.23
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb
new file mode 100644
index 0000000000..1b8af825a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.23.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
+
+SRC_URI[sha256sum] = "76ff246881f528089bf19385131b966197bb494653990396d2ce138e2a447583"
+
+PYPI_PACKAGE = "SQLAlchemy"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-profile \
+"