aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-12-27 14:46:25 +0800
committerKhem Raj <raj.khem@gmail.com>2022-12-27 16:03:06 -0800
commit4b69ca4f39b68c602a8369d1772cbf772844559d (patch)
treea6e78096ca86cd9ff01c85376abc0083c204b359 /meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
parentfa4e825054e9457190135eb884b4cce60fa8fdca (diff)
downloadmeta-openembedded-4b69ca4f39b68c602a8369d1772cbf772844559d.tar.gz
python3-supervisor: upgrade 4.2.4 -> 4.2.5
Changelog: ========== -Fixed a bug where the XML-RPC method supervisor.startProcess() would return 500 Internal Server Error instead of an XML-RPC fault response if the command could not be parsed. -Fixed a bug on Python 2.7 where a UnicodeDecodeError may have occurred when using the web interface. -Removed use of urllib.parse functions splithost, splitport, and splittype deprecated in Python 3.8. -Removed use of asynchat and asyncore deprecated in Python 3.10. -The return value of the XML-RPC method supervisor.getAllConfigInfo() now includes the directory, uid, and serverurl of the program. -If a subprocess exits with a unexpected exit code (one not listed in exitcodes= in a [program:x] section) then the exit will now be logged at the WARN level instead of INFO. -supervisorctl shutdown now shows an error message if an argument is given. -File descriptors are now closed using the faster os.closerange() instead of calling os.close() in a loop. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
deleted file mode 100644
index d677075570..0000000000
--- a/meta-python/recipes-devtools/python/python3-supervisor_4.2.4.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SUMMARY = "Supervisor: A Process Control System"
-DESCRIPTION = "\
-Supervisor is a client/server system that allows its users \
-to monitorand control a number of processes on UNIX-like \
-operating systems."
-HOMEPAGE = "https://github.com/Supervisor/supervisor"
-LICENSE = "BSD-4-Clause"
-LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
-
-SRC_URI[sha256sum] = "40dc582ce1eec631c3df79420b187a6da276bbd68a4ec0a8f1f123ea616b97a2"
-
-PYPI_PACKAGE = "supervisor"
-inherit pypi systemd setuptools3
-RDEPENDS:${PN} = "\
- python3-meld3 \
- python3-io \
- python3-xmlrpc \
- python3-resource \
- python3-setuptools \
- python3-smtpd \
-"
-
-SRC_URI += "file://supervisord.conf \
- file://supervisor.service \
- "
-SYSTEMD_SERVICE:${PN} = "supervisor.service"
-
-do_install:append() {
- install -d ${D}${sysconfdir}/supervisor
- install -d ${D}${systemd_system_unitdir}
-
- install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
- install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
-}