aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sympy_1.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-13 12:48:33 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-15 09:25:26 -0700
commit71acc03cbde585335bce125d6018f29dc70509ca (patch)
tree2dc9a25c73fbdb72cdddf891dc9836407de85111 /meta-python/recipes-devtools/python/python3-sympy_1.8.bb
parent2df3e3aa478ffae71c8e2c99e4d8577460292e51 (diff)
downloadmeta-openembedded-71acc03cbde585335bce125d6018f29dc70509ca.tar.gz
python3-sympy: Upgrade 1.7.1 -> 1.8
Upgrade to release 1.8: assumptions: - Q.infinite now correctly evaluates to True for oo, -oo, and zoo - Assumption predicates now correctly evaluates to None for S.NaN - Relational objects do not need to be wrapped by Q.is_true to be asked or refined anymore - Q.is_true wrapping over AppliedPredicate now just return the argument - refine arg(x) when x is real and nonzero - assumptions/relation module is introduced. This module implements binary relation as predicate - AskHandler(), register_handler() and remove_handler() are deprecated. Handler now must be multipledispatch instance - Predicate now uses a single handler which is multipledispatch instance - Predicate can now take multiple arguments - Predicate("...") now returns UndefinedPredicate instance. To define a predicate, you must make a subclass of Predicate calculus: - Using maximum with a piecewise expression over a domain no longer fails due to a bug fix in Piecewise.as_expr_set_pairs codegen: - allowing for multi-dimensional arrays as arguments/locals in c code generation - create_expand_pow_optimization is now customizable with respect to requirement on base - Support flattening of elementwise additions of array expressions - Fixes to array-expressions in order to properly work with ZeroArray and ZeroMatrix - Fixing matrix expression recognition from array-expressions - Minor fixes to the way the AST of array expressions is built - Add normalization of CodegenArrayDiagonal when it's nested with CodegenArrayPermuteDims and CodegenArrayContraction - Increased support for the normalization of array expressions and permutations of indices - parse_matrix_expression( ) is now able to parse traces of matrices combinatorics: - Added a section to the permutation docs about containment in permutation groups geometry: - Fix AssertError for vertical tangent - Geometric entities with symbolic coordinates will not be printed in SVG simplify: - Fix simplify calls sympify without rational parameter - TRmorrie now takes powers of cos terms into account tensor: - Introduced objects ArraySymbol and ArrayElement for array expressions equivalent to MatrixSymbol and MatrixElement in the matrix expression module - Add class ZeroArray for array expressions of zero-valued elements - Make Array differentiation(derive_by_array) work with non sympy expressions - Added tensordiagonal( ) function to perform diagonalization of array expressions - Adding an array with any other type now consistently gives NotImplemented utilities: - Added official support for using CuPy to GPU accelerate lambdify functions - Added Replacer class to simplify the creation of replacement expressions with MatchPy - Added tests for optional parameter in MatchPy patterns - Added string printers for MatchPy-compatible wildcards in sympy.utilities.matchpy_connector - minlex no longer accepts is_set or small arguments - minlex and least_rotation now accept key= arguments similar to sorted vector: - Fixed a bug with integral over ImplicitRegion objects other: - Expanding documentation to include all class members with docstrings License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sympy_1.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sympy_1.8.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sympy_1.8.bb b/meta-python/recipes-devtools/python/python3-sympy_1.8.bb
new file mode 100644
index 0000000000..3c05c76396
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sympy_1.8.bb
@@ -0,0 +1,15 @@
+# This recipe is adapted from one in meta-jupyter:
+# https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-sympy_1.1.bb
+
+SUMMARY = "Computer algebra system (CAS) in Python"
+HOMEPAGE = "https://pypi.org/project/sympy/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2245824980a408ef1749391dfba32b3b"
+
+SRC_URI[sha256sum] = "1ca588a9f6ce6a323c5592f9635159c2093572826668a1022c75c75bdf0297cb"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-mpmath"
+
+BBCLASSEXTEND = "native nativesdk"