aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tornado_6.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-07-08 16:19:47 +0300
committerKhem Raj <raj.khem@gmail.com>2022-07-11 22:46:17 +0100
commitf2fceed65824efb2603d299fb14441b712a48835 (patch)
treee6b8ee129a8f0f8de65d4ca3a5725ef42da877d4 /meta-python/recipes-devtools/python/python3-tornado_6.1.bb
parented1c1a393e503c8eb4cb2582adf26dc7289a13b1 (diff)
downloadmeta-openembedded-f2fceed65824efb2603d299fb14441b712a48835.tar.gz
python3-tornado: Upgrade 6.1 -> 6.2
Upgrade to release 6.2: - The minimum supported Python version is now 3.7. - Wheels are now published with the Python stable ABI (abi3) for compatibility across versions of Python. - SSL certificate verfication and hostname checks are now enabled by default in more places (primarily in client-side usage of SSLIOStream). - Various improvements to type hints throughout the package. - CI has moved from Travis and Appveyor to Github Actions. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tornado_6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_6.1.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.1.bb b/meta-python/recipes-devtools/python/python3-tornado_6.1.bb
deleted file mode 100644
index 1dedc51029..0000000000
--- a/meta-python/recipes-devtools/python/python3-tornado_6.1.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
-DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
-By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
-polling, WebSockets, and other applications that require a long-lived connection to each user."
-HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI[md5sum] = "f324f5e7607798552359d6ab054c4321"
-SRC_URI[sha256sum] = "33c6e81d7bd55b468d2e793517c909b139960b6c790a60b7991b9b6b76fb9791"
-
-inherit pypi setuptools3
-
-# Requires _compression which is currently located in misc
-RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
- ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
- ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc"
-
-RDEPENDS:${PN}-test += "${PN} ${PYTHON_PN}-unittest"
-
-PACKAGES =+ "\
- ${PN}-test \
-"
-
-FILES:${PN}-test = " \
- ${libdir}/${PYTHON_DIR}/site-packages/*/test \
- ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
-"