aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-07-08 16:19:49 +0300
committerKhem Raj <raj.khem@gmail.com>2022-07-11 22:46:17 +0100
commit6b4b11cf007c028fd8a19a634ed102fbd9e9eacd (patch)
tree06e039d133984fbd39554616731639111b41214b /meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb
parent9b7f4191bfb66c756d197d2f7b5b2bf152e285de (diff)
downloadmeta-openembedded-6b4b11cf007c028fd8a19a634ed102fbd9e9eacd.tar.gz
python3-unidiff: Upgrade 0.7.3 -> 0.7.4
Upgrade to release 0.7.4: - Fixed git diff parsing issues (filename with spaces, only one added/deleted file). Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb b/meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb
new file mode 100644
index 0000000000..3f6d2850fd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-unidiff_0.7.4.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Unified diff parsing/metadata extraction library"
+HOMEPAGE = "http://github.com/matiasb/python-unidiff"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
+
+SRC_URI[sha256sum] = "2bbcbc986e1fb97f04b1d7b864aa6002ab02f4d8a996bf03aa6e5a81447d1fc5"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-io \
+"