aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-11-30 12:47:03 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-09 12:02:15 +0100
commit58ff22a356f8003720ca9fe13749744a2bd02d98 (patch)
treed452715613c48ac1cccfc692bcc426b51bb383af /meta-python/recipes-devtools/python
parent336692f24b5ac6c39b65ff3cb971d7bd353ea4e5 (diff)
downloadmeta-openembedded-58ff22a356f8003720ca9fe13749744a2bd02d98.tar.gz
python-pymongo: update to version 3.3.1
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo_3.3.1.bb (renamed from meta-python/recipes-devtools/python/python-pymongo_3.3.0.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.3.1.bb7
4 files changed, 15 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymongo.inc b/meta-python/recipes-devtools/python/python-pymongo.inc
index 0a256a7cb7..347c49792b 100644
--- a/meta-python/recipes-devtools/python/python-pymongo.inc
+++ b/meta-python/recipes-devtools/python/python-pymongo.inc
@@ -8,5 +8,11 @@ HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2a944942e1496af1886903d274dedb13"
-SRC_URI[md5sum] = "42cd12a5014fb7d3e1987ca04f5c651f"
-SRC_URI[sha256sum] = "3d45302fc2622fabf34356ba274c69df41285bac71bbd229f1587283b851b91e"
+SRC_URI[md5sum] = "0a21c939d66d2459062a4333dab4301b"
+SRC_URI[sha256sum] = "4601cd3120e88fb532478f79f29f8f6deab380343d55ad7702a5aa1af27555b1"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-threading \
+"
diff --git a/meta-python/recipes-devtools/python/python-pymongo_3.3.0.bb b/meta-python/recipes-devtools/python/python-pymongo_3.3.1.bb
index b1778b2f13..b1778b2f13 100644
--- a/meta-python/recipes-devtools/python/python-pymongo_3.3.0.bb
+++ b/meta-python/recipes-devtools/python/python-pymongo_3.3.1.bb
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.3.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.3.0.bb
deleted file mode 100644
index 5164b186bf..0000000000
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.3.0.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-pymongo.inc
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.3.1.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.3.1.bb
new file mode 100644
index 0000000000..55b3b550a5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.3.1.bb
@@ -0,0 +1,7 @@
+inherit pypi setuptools3
+require python-pymongo.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum \
+ ${PYTHON_PN}-selectors \
+"