aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-09-15 14:30:50 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-17 08:36:19 -0700
commita6b48db6fe7cf77b90023301c50febdbb585d967 (patch)
tree7ad582e3ff0534908759f09148d9641a3fd24072 /meta-python/recipes-devtools/python
parentc28aa6bab6e7549c21148d8bf05dc9fac8fd5bf1 (diff)
downloadmeta-openembedded-a6b48db6fe7cf77b90023301c50febdbb585d967.tar.gz
python3-pandas: upgrade 1.3.2 -> 1.3.3
Fixed regressions Fixed regression in DataFrame constructor failing to broadcast for defined Index and len one list of Timestamp Fixed regression in GroupBy.agg() incorrectly raising in some cases Fixed regression in GroupBy.apply() where nan values were dropped even with dropna=False Fixed regression in GroupBy.quantile() which was failing with pandas.NA Fixed regression in merge() where on columns with ExtensionDtype or bool data types were cast to object in right and outer merge Fixed regression in RangeIndex.where() and RangeIndex.putmask() raising AssertionError when result did not represent a RangeIndex Fixed regression in read_parquet() where the fastparquet engine would not work properly with fastparquet 0.7.0 Fixed regression in DataFrame.loc.__setitem__() raising ValueError when setting array as cell value Fixed regression in is_list_like() where objects with __iter__ set to None would be identified as iterable Fixed regression in DataFrame.__getitem__() raising error for slice of DatetimeIndex when index is non monotonic Fixed regression in Resampler.aggregate() when used after column selection would raise if func is a list of aggregation functions Fixed regression in DataFrame.corr() where Kendall correlation would produce incorrect results for columns with repeated values Fixed regression in DataFrame.groupby() where aggregation on columns with object types dropped results on those columns Fixed regression in Series.fillna() raising TypeError when filling float Series with list-like fill value having a dtype which couldn’t cast lostlessly (like float32 filled with float64) Fixed regression in read_csv() raising AttributeError when the file handle is an tempfile.SpooledTemporaryFile object Fixed performance regression in core.window.ewm.ExponentialMovingWindow.mean() Performance improvements Performance improvement for DataFrame.__setitem__() when the key or value is not a DataFrame, or key is not list-like Bug fixes Fixed bug in DataFrameGroupBy.agg() and DataFrameGroupBy.transform() with engine="numba" where index data was not being correctly passed into func Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.3.2.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.2.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb
index 55700b51cf..6e557ed7bc 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
-SRC_URI[sha256sum] = "cbcb84d63867af3411fa063af3de64902665bb5b3d40b25b2059e40603594e87"
+SRC_URI[sha256sum] = "272c8cb14aa9793eada6b1ebe81994616e647b5892a370c7135efb2924b701df"
inherit pypi setuptools3