aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-07-09 21:01:07 -0700
committerKhem Raj <raj.khem@gmail.com>2020-07-12 19:04:17 -0700
commit74c3fc3084c7adce390fe7ca33651ea5949319f8 (patch)
tree22a2cbecd09ad4135a9d86a4d5dc112db980e9ab /meta-python/recipes-devtools
parent48509aec24e819237926cfbc29ccdb1b8ca311ee (diff)
downloadmeta-openembedded-74c3fc3084c7adce390fe7ca33651ea5949319f8.tar.gz
python3-icu: add new package
needed by python3-natsort Signed-off-by: Armin Kuster <akuster808@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch30
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.5.bb13
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch b/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
new file mode 100644
index 0000000000..1b6e890436
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
@@ -0,0 +1,30 @@
+Fixed host contamination of include files
+
+python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used.
+
+Also, don't use icu-config
+
+Upstream-Status: [inappropriate] OE specific
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: PyICU-2.5/setup.py
+===================================================================
+--- PyICU-2.5.orig/setup.py
++++ PyICU-2.5/setup.py
+@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU ma
+
+ CONFIGURE_WITH_ICU_CONFIG = {
+ 'darwin': True,
+- 'linux': True,
++ 'linux': False,
+ 'freebsd': False, # not tested
+ 'win32': False, # no icu-config
+ 'sunos5': False, # not tested
+@@ -274,7 +274,6 @@ setup(name="PyICU",
+ ext_modules=[Extension('_icu',
+ [filename for filename in sorted(os.listdir(os.curdir))
+ if filename.endswith('.cpp')],
+- include_dirs=_includes,
+ extra_compile_args=_cflags,
+ extra_link_args=_lflags,
+ libraries=_libraries)],
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.5.bb b/meta-python/recipes-devtools/python/python3-icu_2.5.bb
new file mode 100644
index 0000000000..5e8c8a3a02
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icu_2.5.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Python extension wrapping the ICU C++ API"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c7c4bfd81a21e3b6368bdcced992bf59"
+
+DEPENDS += "pkgconfig icu"
+
+PYPI_PACKAGE = "PyICU"
+SRC_URI[sha256sum] = "a120b68c53f769f37bfb70b7e84ca12c3f4ab1e4df43e87a02dff05ae472cdbc"
+
+SRC_URI += "file://fix_host_include.patch"
+
+inherit pypi setuptools3