aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-21 13:58:25 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-22 09:59:30 -0700
commit9b6333a55429a791d455a70b29cdfdd897e029bb (patch)
tree5f251c3a950d0f64918a1ad1733c669dd2112824 /meta-python/recipes-devtools
parent39f4be78292c533090307c63415b18e6da04d9d6 (diff)
downloadmeta-openembedded-9b6333a55429a791d455a70b29cdfdd897e029bb.tar.gz
python3-mypy: Upgrade 0.812 -> 0.902
Upgrade to release 0.902: - Move third-party library stubs to stub packages, allowing newer stubs to be easily used without updating mypy - Support pyproject.toml and type guards - Ship wheels for Apple Silicon - Many other features and bug fixes License-Update: Update copyright year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-mypy_0.902.bb (renamed from meta-python/recipes-devtools/python/python3-mypy_0.812.bb)12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.812.bb b/meta-python/recipes-devtools/python/python3-mypy_0.902.bb
index 8faab60b97..86465e2f3a 100644
--- a/meta-python/recipes-devtools/python/python3-mypy_0.812.bb
+++ b/meta-python/recipes-devtools/python/python3-mypy_0.902.bb
@@ -1,7 +1,7 @@
SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
HOMEPAGE = "https://github.com/python/mypy"
LICENSE = "MIT & Python-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6afb7c151c4dedb5c3dc292cc120fadc"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=17b7180fcfc43c4e70c07c71588604c4"
RDEPENDS_${PN} = " \
${PYTHON_PN}-mypy-extensions \
@@ -13,6 +13,14 @@ PYPI_PACKAGE = "mypy"
inherit pypi setuptools3
-SRC_URI[sha256sum] = "cd07039aa5df222037005b08fbbfd69b3ab0b0bd7a07d7906de75ae52c4e3119"
+SRC_URI[sha256sum] = "9236c21194fde5df1b4d8ebc2ef2c1f2a5dc7f18bcbea54274937cae2e20a01c"
BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-toml \
+"