aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-05-24 13:11:53 +0100
committerKhem Raj <raj.khem@gmail.com>2022-05-29 06:39:14 -0700
commita2790f4316d8e82299723c27526d866f5f931ca7 (patch)
tree155f67d04f7476ae762303059b489516ad41419b /meta-python/recipes-devtools
parent50e60e6549741a466a258d07389a2f26bd8e07f3 (diff)
downloadmeta-openembedded-a2790f4316d8e82299723c27526d866f5f931ca7.tar.gz
python3-cppy: fix inherits and DEPENDS
This recipe inherited python_flit_core, but actually builds with setuptools. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
index 57ef3b2776..270f74963d 100644
--- a/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
@@ -7,11 +7,11 @@ SRC_URI[sha256sum] = "83b43bf17b1085ac15c5debdb42154f138b928234b21447358981f69d0
RDEPENDS:${PN} += "python3-setuptools python3-distutils"
-inherit pypi python_flit_core
+inherit pypi python_setuptools_build_meta
SRC_URI += " file://0001-Fix-build-error-as-following.patch \
"
-DEPENDS += "python3-setuptools-native"
+DEPENDS += "python3-setuptools-scm-native"
BBCLASSEXTEND = "native nativesdk"