aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-08-27 20:45:10 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:18:34 +0200
commit104f6413d2b8affc9133a3623bd677d99df9c31e (patch)
tree49e94f1e863d31657378a36c431a7b3706b6e34a /meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
parentfaf070c45a67f0ad49f52bc4cb79a77f64842d93 (diff)
downloadmeta-openembedded-104f6413d2b8affc9133a3623bd677d99df9c31e.tar.gz
python-pyparted: update to 3.10.5
* add patch to fix float cast error when version is x.y.z form * add minimal parted version (>= 2.3) to RDEPENDS NOTE: If your tree defaults to an earlier parted version (e.g. 1.8.6), you will need to add PREFERRED_VERSION_parted = "3.%" to local.conf or you will see a do_compile error (complaining about required libparted version). Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch b/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
new file mode 100644
index 0000000000..db3ab9fc3e
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
@@ -0,0 +1,26 @@
+check_mod_version breaks if module version is of x.y.z form
+use a regex to help cast x.y.z version to a float
+
+Upstream-Status: Pending
+
+Index: git/setup.py
+===================================================================
+--- git.orig/setup.py
++++ git/setup.py
+@@ -25,6 +25,7 @@ import glob
+ import os
+ import platform
+ import sys
++import re
+ from distutils.ccompiler import new_compiler
+ from distutils.errors import CompileError
+ from distutils.errors import LinkError
+@@ -51,6 +52,8 @@ def pkgconfig(*packages, **kwargs):
+
+ def check_mod_version(module, version):
+ modversion = subprocess.check_output(["pkg-config", "--modversion", module])
++ match = re.search('([0-9]+\.[0-9]+)', modversion)
++ modversion = match.group(0)
+ if not float(modversion) >= float(version):
+ sys.stderr.write("*** Minimum required %s version: %s, found: %s\n" % (module, version, modversion,))
+ sys.exit(1)