aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-25 20:01:50 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-28 08:32:19 -0800
commit9cd74b558f4f0b88acb120a406de0b938ba77f8e (patch)
tree9230a1a21e3f5a21750a807ca0f5354093648944 /meta-python/recipes-extended
parent33ac9025c64d226441f1b86ab0fe84bdff6c5459 (diff)
downloadmeta-openembedded-9cd74b558f4f0b88acb120a406de0b938ba77f8e.tar.gz
python3-pykickstart: fix wheel build
Recipe does not inherit pypi, nor is PN a reasonable guess for the wheel name so set PIP_INSTALL_PACKAGE appropriately. The wheel is built in ${S}/dist rather than ${B}/dist so set PIP_INSTALL_DIST_PATH appropriately. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.34.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.34.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.34.bb
index 65fc88e77b..7aa0758400 100644
--- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.34.bb
+++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.34.bb
@@ -23,3 +23,5 @@ SRCREV = "bfd836cfdd8439d984595aca015811ed5c6be733"
UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
inherit setuptools3
+PIP_INSTALL_PACKAGE = "pykickstart"
+PIP_INSTALL_DIST_PATH = "${S}/dist"