aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-01-24 18:01:18 +0200
committerKhem Raj <raj.khem@gmail.com>2023-01-25 08:57:42 -0800
commitd11c3b828f37e20a8b663a7f26d7896d1150aa18 (patch)
tree0694b09f558fd7c9e9edc150f782e32da7f4783f /meta-python
parent75a836190adb7822da1ae71de076ddeb91b60db9 (diff)
downloadmeta-openembedded-d11c3b828f37e20a8b663a7f26d7896d1150aa18.tar.gz
python3-nocaselist: Upgrade 1.0.6 -> 1.1.0
Upgrade to release 1.1.0: - The default casefolding method on Python 3 was changed from str.lower() to str.casefold(). This changes the matching of the case-insensitive values. This shold normally be an improvement, but in case you find that you are negatively affected by this change, you can go back to the str.lower() method by overriding the NocaseDict.__casefold__() method with a method that calls str.lower(). - Added support for Python 3.11. - Changed the default casefolding method on Python 3 to be str.casefold() in order to improve Unicode support. On Python 2, it remains str.lower(). Added support for user-defined casefolding. - Added support for storing None as a value in a NocaseList. Previously, that was rejected with AttributeError since the casefold method was attempted to be called on the None value. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-nocaselist_1.1.0.bb (renamed from meta-python/recipes-devtools/python/python3-nocaselist_1.0.6.bb)6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-nocaselist_1.0.6.bb b/meta-python/recipes-devtools/python/python3-nocaselist_1.1.0.bb
index 9e6842961d..4b93ca98fa 100644
--- a/meta-python/recipes-devtools/python/python3-nocaselist_1.0.6.bb
+++ b/meta-python/recipes-devtools/python/python3-nocaselist_1.1.0.bb
@@ -3,6 +3,10 @@ HOMEPAGE = "https://nocaselist.readthedocs.io/en/latest/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI[sha256sum] = "48f067f8cb841245f34d03120bc1ba9900f13b19cb51bcc6c7bee017f7c874da"
+SRC_URI[sha256sum] = "a99384abc700c409e9def7143763e18dfad332fdff7e30fae1f6d1a30b372772"
inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-six \
+"