aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins/systemload
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-05 20:07:38 -0800
committerKhem Raj <raj.khem@gmail.com>2023-11-06 08:49:52 -0800
commitcb6c08579e3a717ab58498a312d705e634b53e2b (patch)
treed11cc651d78bfde71470b680bcfc7383b809b8df /meta-xfce/recipes-panel-plugins/systemload
parentd8688486c82106bb728e9811d5bdf98d46c9ab5c (diff)
downloadmeta-openembedded-cb6c08579e3a717ab58498a312d705e634b53e2b.tar.gz
xfce4-systemload-plugin: Fix build on 32bit machines
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/systemload')
-rw-r--r--meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin/convert-gulong.patch39
-rw-r--r--meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin_1.3.2.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin/convert-gulong.patch b/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin/convert-gulong.patch
new file mode 100644
index 0000000000..30897caab3
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin/convert-gulong.patch
@@ -0,0 +1,39 @@
+Fix build on 32bit architectures
+
+It fails with errors like
+| ../../xfce4-systemload-plugin-1.3.2/panel-plugin/network.cc:126:13: error: no matching function for call to 'read_netload_libgtop'
+| 126 | if (read_netload_libgtop (&bytes[1]) != 0)
+| | ^~~~~~~~~~~~~~~~~~~~
+| ../../xfce4-systemload-plugin-1.3.2/panel-plugin/network.cc:42:1: note: candidate function not viable: no known conversion from 'guint64 *' (aka 'unsigned long long *') to 'gulong *' (aka 'unsigne
+d long *') for 1st argument
+| 42 | read_netload_libgtop (gulong *bytes)
+| | ^ ~~~~~~~~~~~~~
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/panel-plugin/network.cc
++++ b/panel-plugin/network.cc
+@@ -114,6 +114,7 @@ read_netload_proc (gulong *bytes)
+ gint
+ read_netload (gulong *net, gulong *NTotal)
+ {
++ gulong tbytes[2];
+ static guint64 bytes[2];
+ static gint64 time[2];
+
+@@ -122,10 +123,12 @@ read_netload (gulong *net, gulong *NTota
+
+ time[1] = g_get_monotonic_time ();
+
+- if (read_netload_proc (&bytes[1]) != 0)
+- if (read_netload_libgtop (&bytes[1]) != 0)
++ if (read_netload_proc (&tbytes[1]) != 0)
++ if (read_netload_libgtop (&tbytes[1]) != 0)
+ return -1;
+
++ bytes[0] = tbytes[0];
++ bytes[1] = tbytes[1];
+ if (time[0] != 0 && G_LIKELY (time[1] > time[0]) && G_LIKELY (bytes[1] >= bytes[0]))
+ {
+ guint64 diff_bits = 8 * (bytes[1] - bytes[0]);
diff --git a/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin_1.3.2.bb b/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin_1.3.2.bb
index 46fd47c126..e7a3e9936e 100644
--- a/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin_1.3.2.bb
+++ b/meta-xfce/recipes-panel-plugins/systemload/xfce4-systemload-plugin_1.3.2.bb
@@ -9,4 +9,5 @@ PACKAGECONFIG ?= "network power"
PACKAGECONFIG[power] = ",,upower"
PACKAGECONFIG[network] = ",,libgtop"
+SRC_URI += "file://convert-gulong.patch"
SRC_URI[sha256sum] = "bb303fc3020e053ad1fa0b8fcbf0d7681c5563bb8f649357d6a95a577802b072"