aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commitf08b75f64ccf52c416a2ebaeb2e27d1e50877583 (patch)
tree714583f0f25a207e60f003d73419473ef66831f9 /meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb
parente5c807b77fbe753e28483ae7d58d8a5dec676ace (diff)
downloadmeta-openembedded-f08b75f64ccf52c416a2ebaeb2e27d1e50877583.tar.gz
meta-xfce: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb
index fa38c8af09..81b6771f5a 100644
--- a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb
+++ b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb
@@ -18,7 +18,7 @@ EXTRA_OECONF = " \
--enable-panel-plugins \
"
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','systemd','systemd','',d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit"
PACKAGES += "xfce4-powermanager-plugin"
@@ -34,7 +34,7 @@ FILES_xfce4-powermanager-plugin = " \
"
RDEPENDS_xfce4-powermanager-plugin = "${PN}"
-RDEPENDS_${PN} = "networkmanager ${@base_contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
+RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
# xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"