aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-setuptools-declarative-requirements_1.2.0.bb12
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 722e716dd1..0721c6c0d3 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -392,6 +392,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-send2trash \
python3-sentry-sdk \
python3-serpent \
+ python3-setuptools-declarative-requirements \
python3-setuptools-scm-git-archive \
python3-sh \
python3-sijax \
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-declarative-requirements_1.2.0.bb b/meta-python/recipes-devtools/python/python3-setuptools-declarative-requirements_1.2.0.bb
new file mode 100644
index 0000000000..9628656ad6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-setuptools-declarative-requirements_1.2.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "File support for setuptools declarative setup.cfg"
+HOMEPAGE = "https://pypi.org/project/setuptools-declarative-requirements/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[sha256sum] = "d11fdb5ef818c65b20bc241e0f5ef44905a5640b681dae21ba1ac1742dab1fd1"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"