aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch28
-rw-r--r--meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb13
3 files changed, 13 insertions, 39 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch
deleted file mode 100644
index ed6ceca8e1..0000000000
--- a/meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ad9024e50a9df4a2b8a1a019e07bb133c3df31bf Mon Sep 17 00:00:00 2001
-From: Daniel Watkins <daniel@daniel-watkins.co.uk>
-Date: Thu, 28 Aug 2014 18:49:04 +0200
-Subject: [PATCH] Switch from using distutils to setuptools.
-
-Upstream-Status: Backport
-
-Signed-off-by: Tim Orling <tim.orling@konsulko.com>
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index c6d57a6..6755ab4 100644
---- a/setup.py
-+++ b/setup.py
-@@ -12,7 +12,7 @@
- # http://opensource.org/licenses/BSD-3-Clause
- import os
- import sys
--from distutils.core import setup
-+from setuptools import setup
- # a simple import wouldn't work if we moved towards a package with __init__
- from _version import __version__
-
---
-2.30.2
-
diff --git a/meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb b/meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb
deleted file mode 100644
index 1125a6389d..0000000000
--- a/meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-SUMMARY = "Config file reading, writing and validation."
-SECTION = "devel/python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://configobj.py;md5=a7c3968dd866dfd23e91e125b669ab21"
-
-PYPI_PACKAGE = "configobj"
-SRC_URI[sha256sum] = "a2f5650770e1c87fb335af19a9b7eb73fc05ccf22144eb68db7d00cd2bcb0902"
-
-SRC_URI += "file://0001-Switch-from-using-distutils-to-setuptools.patch"
-
-inherit pypi setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb b/meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb
new file mode 100644
index 0000000000..b8b5e6f897
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Config file reading, writing and validation."
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3d6f99b84d9a94610c62e48fa2e59e72"
+
+PYPI_PACKAGE = "configobj"
+SRC_URI[sha256sum] = "6f704434a07dc4f4dc7c9a745172c1cad449feb548febd9f7fe362629c627a97"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-six \
+"