aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gimp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gimp')
-rw-r--r--meta-gnome/recipes-gimp/babl/babl_0.1.108.bb (renamed from meta-gnome/recipes-gimp/babl/babl_0.1.86.bb)13
-rw-r--r--meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch28
-rw-r--r--meta-gnome/recipes-gimp/gegl/gegl_0.4.48.bb (renamed from meta-gnome/recipes-gimp/gegl/gegl_0.4.30.bb)31
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch30
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch34
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp_2.10.36.bb (renamed from meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb)24
-rw-r--r--meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb4
-rw-r--r--meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb2
8 files changed, 100 insertions, 66 deletions
diff --git a/meta-gnome/recipes-gimp/babl/babl_0.1.86.bb b/meta-gnome/recipes-gimp/babl/babl_0.1.108.bb
index d264bf8c51..e0685f781d 100644
--- a/meta-gnome/recipes-gimp/babl/babl_0.1.86.bb
+++ b/meta-gnome/recipes-gimp/babl/babl_0.1.108.bb
@@ -1,20 +1,17 @@
SUMMARY = "Babl is a dynamic, any to any, pixel format conversion library"
-LICENSE = "LGPL-3.0"
+LICENSE = "LGPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
-GNOMEBASEBUILDCLASS = "meson"
-
GIR_MESON_OPTION = "enable-gir"
+VALA_MESON_OPTION = "enable-vapi"
inherit setuptools3 gnomebase gobject-introspection vala
DEPENDS += "lcms"
-# https://bugs.llvm.org/show_bug.cgi?id=45555
-CFLAGS_append_toolchain-clang_mipsarch = " -ffp-exception-behavior=ignore "
-CFLAGS_append_toolchain-clang_riscv64 = " -ffp-exception-behavior=ignore "
-
SRC_URI = "https://download.gimp.org/pub/${BPN}/0.1/${BP}.tar.xz"
-SRC_URI[sha256sum] = "0b3f595159ad1b216cd729c0504c3a5f6cf780c641f4dc63fc164f3c0382c8f0"
+SRC_URI[sha256sum] = "26defe9deaab7ac4d0e076cab49c2a0d6ebd0df0c31fd209925a5f07edee1475"
+
+FILES:${PN} += "${libdir}/${BPN}-${@gnome_verdir("${PV}")}"
BBCLASSEXTEND = "native"
diff --git a/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch b/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch
deleted file mode 100644
index b2f13afd5d..0000000000
--- a/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 073d622fbf8564271cd9be87c2f619ea00498578 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 1 May 2021 08:25:24 -0700
-Subject: [PATCH] Fix build with OpenEXR 3
-
-Add a header that is no longer transitively included
-
-Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gegl/-/merge_requests/96]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- operations/external/exr-save.cc | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/operations/external/exr-save.cc b/operations/external/exr-save.cc
-index 1e8c09d..87abed5 100644
---- a/operations/external/exr-save.cc
-+++ b/operations/external/exr-save.cc
-@@ -45,6 +45,7 @@ extern "C" {
- #include <ImfChromaticities.h>
- #include <ImfStandardAttributes.h>
- #include <ImfArray.h>
-+#include <ImfFrameBuffer.h>
- #include "ImathRandom.h"
-
-
---
-2.31.1
-
diff --git a/meta-gnome/recipes-gimp/gegl/gegl_0.4.30.bb b/meta-gnome/recipes-gimp/gegl/gegl_0.4.48.bb
index bb0cd1f8a9..34e001a5f7 100644
--- a/meta-gnome/recipes-gimp/gegl/gegl_0.4.30.bb
+++ b/meta-gnome/recipes-gimp/gegl/gegl_0.4.48.bb
@@ -1,12 +1,11 @@
SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7"
DEPENDS = " \
intltool-native \
babl \
glib-2.0 \
- pango \
cairo \
expat \
zlib \
@@ -14,22 +13,23 @@ DEPENDS = " \
json-glib \
"
-GNOMEBASEBUILDCLASS = "meson"
+DEPENDS:append:toolchain-clang = " openmp"
+DEPENDS:remove:toolchain-clang:riscv32 = "openmp"
+DEPENDS:remove:toolchain-clang:powerpc = "openmp"
-inherit features_check gnomebase vala gobject-introspection
+VALA_MESON_OPTION = ""
-REQUIRED_DISTRO_FEATURES = "x11"
+inherit features_check gnomebase gobject-introspection vala
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
SHPV = "${@gnome_verdir("${PV}")}"
-SRC_URI = " \
- https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \
- file://0001-Fix-build-with-OpenEXR-3.patch \
-"
-SRC_URI[sha256sum] = "c112782cf4096969e23217ccdfabe42284e35d5435ff0c43d40e4c70faeca8dd"
+SRC_URI = "https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz"
+SRC_URI[sha256sum] = "418c26d94be8805d7d98f6de0c6825ca26bd74fcacb6c188da47533d9ee28247"
-PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg poppler sdl2"
-PACKAGECONFIG_class-native = "libpng librsvg"
+PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg pango poppler sdl2"
+PACKAGECONFIG:class-native = "libpng librsvg"
PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper"
PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2"
@@ -40,14 +40,15 @@ PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav"
PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng"
PACKAGECONFIG[libraw] = "-Dlibraw=enabled,-Dlibraw=disabled,libraw"
PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg"
+PACKAGECONFIG[pango] = "-Dpango=enabled -Dpangocairo=enabled,-Dpango=disabled -Dpangocairo=disabled,pango"
PACKAGECONFIG[poppler] = "-Dpoppler=enabled,-Dpoppler=disabled,poppler"
-PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl"
-PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2"
+PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,libsdl"
+PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,libsdl2"
PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff"
PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp"
# There are a couple of non-symlink .so files installed into libdir, which need to go into main package
-FILES_${PN} += " \
+FILES:${PN} += " \
${libdir}/*.so \
${libdir}/gegl-${SHPV}/*.json \
${libdir}/gegl-${SHPV}/*.so \
diff --git a/meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch b/meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch
new file mode 100644
index 0000000000..618b4cc7a7
--- /dev/null
+++ b/meta-gnome/recipes-gimp/gimp/gimp/0001-configure-Keep-first-line-of-compiler-version-string.patch
@@ -0,0 +1,30 @@
+From 5711ccfab40e304ced7f5be39a4083e3fcecff91 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 24 May 2023 22:22:41 -0700
+Subject: [PATCH] configure: Keep first line of compiler version string
+
+Full output of cc -v may contain additional information which could
+contain build path information, which is unnessasary
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gimp/-/merge_requests/926]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c25415d..68707a0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -599,7 +599,7 @@ fi
+ for CC_VERSION_OPT in $CC_VERSION_OPTS; do
+ # We run $CC, and escape and format its output, in a single step,
+ # since some shells expand escape sequences in "echo" arguments.
+- CC_VERSION="`$CC $CC_VERSION_OPT 2>&1 | sed -e 's/\\\\/\\\\\\\\\\\\\\\\/g;s/^/\\\\t/;s/$/\\\\n/' | tr -d '\n'`"
++ CC_VERSION="`$CC $CC_VERSION_OPT 2>&1 | head -1 | sed -e 's/\\\\/\\\\\\\\\\\\\\\\/g;s/^/\\\\t/;s/$/\\\\n/' | tr -d '\n'`"
+ if test $? -eq 0; then
+ break
+ fi
+--
+2.40.1
+
diff --git a/meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch b/meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch
new file mode 100644
index 0000000000..cec0055284
--- /dev/null
+++ b/meta-gnome/recipes-gimp/gimp/gimp/0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch
@@ -0,0 +1,34 @@
+From c720df90dfe3a3e92e34bfb36a04cc792064a501 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 24 May 2023 22:39:02 -0700
+Subject: [PATCH] libtool: Do not add build time library paths to
+ LD_LIBRARY_PATH
+
+This does not serve much purpose on cross builds as it will add build
+time paths which are only useful when trying to run these tools from
+build area but when they are cross built this is not possible to run
+them like this.
+
+Upstream-Status: Inappropriate [Cross-compile specific]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ ltmain.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ltmain.sh b/ltmain.sh
+index 134902c..068d74a 100644
+--- a/ltmain.sh
++++ b/ltmain.sh
+@@ -5748,7 +5748,7 @@ func_exec_program ()
+ if test yes = "$shlibpath_overrides_runpath" && test -n "$shlibpath_var" && test -n "$temp_rpath"; then
+ $ECHO "\
+ # Add our own library path to $shlibpath_var
+- $shlibpath_var=\"$temp_rpath\$$shlibpath_var\"
++ $shlibpath_var=\"$shlibpath_var\"
+
+ # Some systems cannot cope with colon-terminated $shlibpath_var
+ # The second colon is a workaround for a bug in BeOS R4 sed
+--
+2.40.1
+
diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.36.bb
index e729d9deb7..4526839ad6 100644
--- a/meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb
+++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.36.bb
@@ -1,7 +1,7 @@
SUMMARY = "The GIMP is the GNU Image Manipulation Program"
HOMEPAGE = "http://www.gimp.org"
SECTION = "x11/graphics"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
DEPENDS = " \
@@ -35,38 +35,38 @@ DEPENDS = " \
libmng \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
"
-DEPENDS_append_libc-musl = " libexecinfo"
+DEPENDS:append:libc-musl = " libexecinfo"
+GNOMEBASEBUILDCLASS = "autotools"
inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
REQUIRED_DISTRO_FEATURES = "x11"
SHPV = "${@gnome_verdir("${PV}")}"
-SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
-SRC_URI[sha256sum] = "bd1bb762368c0dd3175cf05006812dd676949c3707e21f4e6857435cb435989e"
+SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \
+ file://0001-configure-Keep-first-line-of-compiler-version-string.patch \
+ file://0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch"
+SRC_URI[sha256sum] = "3d3bc3c69a4bdb3aea9ba2d5385ed98ea03953f3857aafd1d6976011ed7cdbb2"
EXTRA_OECONF = "--disable-python \
--without-webkit \
--disable-check-update \
--without-wmf"
-EXTRA_OECONF_append_mipsarch = " --disable-vector-icons"
-EXTRA_OECONF_append_libc-musl_riscv32 = " --disable-vector-icons"
-EXTRA_OECONF_append_libc-musl_x86 = " --disable-vector-icons"
-EXTRA_OECONF_append_toolchain-clang_arm = " --disable-vector-icons"
+EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '32', ' --disable-vector-icons', '', d)}"
-do_configure_append() {
+do_configure:append() {
find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
}
-do_compile_prepend() {
+do_compile:prepend() {
# Let native babl/gegl find their plugins
export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
}
-FILES_${PN} += "${datadir}/metainfo"
+FILES:${PN} += "${datadir}/metainfo"
-RDEPENDS_${PN} += "mypaint-brushes-1.0"
+RDEPENDS:${PN} += "mypaint-brushes-1.0"
diff --git a/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb b/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
index e711a2a7fa..d509aa3dd0 100644
--- a/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
+++ b/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
@@ -10,7 +10,7 @@ DEPENDS = " \
json-c \
"
-inherit autotools gobject-introspection gettext python3native
+inherit autotools gobject-introspection gettext pkgconfig python3native
SRC_URI = "git://github.com/mypaint/libmypaint.git;protocol=https;branch=libmypaint-v1 \
file://0001-make-build-compatible-w.-autoconf-2.7.patch \
@@ -19,7 +19,7 @@ SRCREV = "2768251dacce3939136c839aeca413f4aa4241d0"
PV = "1.6.1"
S = "${WORKDIR}/git"
-do_configure_append() {
+do_configure:append() {
# autogen uses python2 so generate headers ourselves
cd ${S}
python3 generate.py mypaint-brush-settings-gen.h brushsettings-gen.h
diff --git a/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb b/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb
index 4ecc2fef8b..ca3912da88 100644
--- a/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb
+++ b/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb
@@ -9,4 +9,4 @@ SRCREV = "8a0124ac0675103eae8fa41fad533851768ae1ce"
PV = "1.3.1"
S = "${WORKDIR}/git"
-FILES_${PN} += "${datadir}/mypaint-data"
+FILES:${PN} += "${datadir}/mypaint-data"