aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/rest
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/rest')
-rw-r--r--meta-gnome/recipes-gnome/rest/librest_0.8.1.bb (renamed from meta-gnome/recipes-gnome/rest/rest_0.8.1.bb)20
-rw-r--r--meta-gnome/recipes-gnome/rest/rest_0.9.1.bb24
2 files changed, 34 insertions, 10 deletions
diff --git a/meta-gnome/recipes-gnome/rest/rest_0.8.1.bb b/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
index e875f7a7d0..63372afa5d 100644
--- a/meta-gnome/recipes-gnome/rest/rest_0.8.1.bb
+++ b/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
@@ -1,33 +1,33 @@
SUMMARY = "library to access web services that claim to be "RESTful""
HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
-LICENSE = "LGPLv2.1"
+LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
-GNOMEBASEBUILDCLASS = "autotools"
-
DEPENDS = " \
- libxml2-native \
- glib-2.0-native \
glib-2.0 \
+ glib-2.0-native \
libsoup-2.4 \
+ libxml2 \
"
-inherit gnomebase gobject-introspection gtk-doc vala
+GNOMEBASEBUILDCLASS = "autotools"
+inherit gnomebase gobject-introspection vala pkgconfig gtk-doc
+
+GNOMEBN = "rest"
-SRC_URI[archive.md5sum] = "ece4547298a81105f307369d73c21b9d"
SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
+S = "${WORKDIR}/${GNOMEBN}-${PV}"
# * gnome environment requires libsoup build with in gnome PACKAGECONFIG
# * libsoup-gnome support was removed upstream three years ago [1]
# [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
EXTRA_OECONF = "--without-gnome"
-do_configure_prepend() {
+do_configure:prepend() {
# rest expects introspection.m4 at custom location (see aclocal.m4).
cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
}
-do_compile_prepend() {
+do_compile:prepend() {
export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
}
-
diff --git a/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb b/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb
new file mode 100644
index 0000000000..3b22fdfea2
--- /dev/null
+++ b/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "library to access web services that claim to be "RESTful""
+HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+
+DEPENDS = " \
+ glib-2.0 \
+ glib-2.0-native \
+ gtksourceview5 \
+ json-glib \
+ libadwaita \
+ libsoup-3.0 \
+ libxml2-native \
+"
+
+inherit gnomebase gobject-introspection vala pkgconfig gi-docgen features_check
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false"
+PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
+
+SRC_URI[archive.sha256sum] = "9266a5c10ece383e193dfb7ffb07b509cc1f51521ab8dad76af96ed14212c2e3"