aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/tepl/tepl_6.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/tepl/tepl_6.8.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/tepl/tepl_6.8.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/tepl/tepl_6.8.0.bb b/meta-gnome/recipes-gnome/tepl/tepl_6.8.0.bb
new file mode 100644
index 0000000000..6c9c36f3ed
--- /dev/null
+++ b/meta-gnome/recipes-gnome/tepl/tepl_6.8.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Tepl library eases the development of GtkSourceView-based projects"
+LICENSE = "LGPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSES/LGPL-3.0-or-later.txt;md5=c51d3eef3be114124d11349ca0d7e117"
+
+DEPENDS = " \
+ gsettings-desktop-schemas \
+ glib-2.0 \
+ gtk+3 \
+ libgedit-amtk \
+ libgedit-gtksourceview \
+ libxml2 \
+ uchardet \
+ gtk-doc-native \
+ libxslt-native \
+ docbook-xsl-stylesheets-native \
+ python3-pygments-native \
+"
+
+inherit meson gobject-introspection gettext features_check pkgconfig
+
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+SRC_URI = "git://gitlab.gnome.org/swilmet/tepl;protocol=https;branch=main"
+SRCREV = "16ab2567257a053bd957699f89080fafd0999035"
+S = "${WORKDIR}/git"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
+GIR_MESON_OPTION = ""
+
+GTKDOC_MESON_OPTION = "gtk_doc"