aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch')
-rw-r--r--meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch b/meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch
index c2310fe46c..944d2f9165 100644
--- a/meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch
+++ b/meta-gnome/recipes-support/accountsservice/accountsservice/0001-musl-Hack-to-fix-build.patch
@@ -1,25 +1,25 @@
-From 2a1c7103839c20df5ca9ce2fa863535d802f8f3a Mon Sep 17 00:00:00 2001
+From ff0718174faf1167fb4765ebe4bd280bbe8d2ac6 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 8 Dec 2019 23:42:00 +0100
Subject: [PATCH] musl: Hack to fix configure
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
+Upstream-Status: Inappropriate [Musl Specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- meson.build | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
+ meson.build | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
-index 4465a26..726c9fe 100644
+index 075776f..dfd7421 100644
--- a/meson.build
+++ b/meson.build
-@@ -82,8 +82,14 @@ if cc.has_header_symbol('utmpx.h', 'WTMPX_FILENAME', prefix: '#define _GNU_SOURC
- elif cc.has_header_symbol('paths.h', '_PATH_WTMPX')
+@@ -101,9 +101,14 @@ elif cc.has_header_symbol('paths.h', '_PATH_WTMPX')
+
config_h.set('PATH_WTMP', '_PATH_WTMPX')
else
-- assert(run_command('test', '-e', '/var/log/utx.log').returncode() == 0, 'Do not know which filename to watch for wtmp changes')
-- config_h.set_quoted('PATH_WTMP', '/var/log/utx.log')
+- path_wtmp = '/var/log/utx.log'
+- assert(run_command('test', '-e', path_wtmp).returncode() == 0, 'Do not know which filename to watch for wtmp changes')
+- config_h.set_quoted('PATH_WTMP', path_wtmp)
+ # musl: This is just a build fix hack.
+ # As usual they know better, consider all other projects crap and offer zero
+ # alternatives: So wtmp is a dead stub only [1] (= /dev/null/wtmp - taken
@@ -32,5 +32,5 @@ index 4465a26..726c9fe 100644
# compiler flags
--
-2.21.0
+2.34.1