aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/evince/evince/0002-add-a-formatting-attribute-check.patch29
-rw-r--r--meta-gnome/recipes-gnome/evince/evince_3.36.3.bb (renamed from meta-gnome/recipes-gnome/evince/evince_3.34.2.bb)19
2 files changed, 11 insertions, 37 deletions
diff --git a/meta-gnome/recipes-gnome/evince/evince/0002-add-a-formatting-attribute-check.patch b/meta-gnome/recipes-gnome/evince/evince/0002-add-a-formatting-attribute-check.patch
index c374fc9430..94794a5f92 100644
--- a/meta-gnome/recipes-gnome/evince/evince/0002-add-a-formatting-attribute-check.patch
+++ b/meta-gnome/recipes-gnome/evince/evince/0002-add-a-formatting-attribute-check.patch
@@ -19,17 +19,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
cut-n-paste/unarr/common/unarr.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
---- a/cut-n-paste/unarr/common/unarr.c
-+++ b/cut-n-paste/unarr/common/unarr.c
-@@ -92,7 +92,7 @@ size_t ar_get_global_comment(ar_archive
- return ar->get_comment(ar, buffer, count);
- }
-
--void ar_log(const char *prefix, const char *file, int line, const char *msg, ...)
-+void __attribute__((__format__ (__printf__, 4, 5))) ar_log(const char *prefix, const char *file, int line, const char *msg, ...)
- {
- va_list args;
- va_start(args, msg);
--- a/cut-n-paste/synctex/synctex_parser_utils.c
+++ b/cut-n-paste/synctex/synctex_parser_utils.c
@@ -87,11 +87,11 @@ void _synctex_free(void * ptr) {
@@ -76,24 +65,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
result = NULL;
return NULL;
}
---- a/cut-n-paste/synctex/synctex_parser.c
-+++ b/cut-n-paste/synctex/synctex_parser.c
-@@ -8411,6 +8411,7 @@ struct synctex_updater_t {
- int length; /* the number of chars appended */
- };
-
-+static int _synctex_updater_print(synctex_updater_p updater, const char * format, ...) SYNCTEX_PRINTF_FORMAT(2, 3);
- static int _synctex_updater_print(synctex_updater_p updater, const char * format, ...) {
- int result = 0;
- if (updater) {
-@@ -8447,6 +8448,7 @@ static int vasprintf(char **ret,
- /**
- * gzvprintf is not available until OSX 10.10
- */
-+static int _synctex_updater_print_gz(synctex_updater_p updater, const char * format, ...) SYNCTEX_PRINTF_FORMAT(2, 3);
- static int _synctex_updater_print_gz(synctex_updater_p updater, const char * format, ...) {
- int result = 0;
- if (updater) {
--- a/cut-n-paste/synctex/synctex_parser_utils.h
+++ b/cut-n-paste/synctex/synctex_parser_utils.h
@@ -85,7 +85,11 @@ extern "C" {
diff --git a/meta-gnome/recipes-gnome/evince/evince_3.34.2.bb b/meta-gnome/recipes-gnome/evince/evince_3.36.3.bb
index b792d4fcb1..08a20d4e0d 100644
--- a/meta-gnome/recipes-gnome/evince/evince_3.34.2.bb
+++ b/meta-gnome/recipes-gnome/evince/evince_3.36.3.bb
@@ -16,18 +16,21 @@ DEPENDS = " \
${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop3','',d)} \
"
-inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection upstream-version-is-even gettext features_check mime-xdg
+GNOMEBASEBUILDCLASS = "meson"
-SRC_URI[archive.md5sum] = "9e9e82fa8f6045ad7817157d9335d185"
-SRC_URI[archive.sha256sum] = "3cc0955f11204e3a2db1c7ab99b866692749592257485b87304134ad69da0617"
+inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection upstream-version-is-even gettext features_check mime-xdg gtk-doc
+
+SRC_URI[archive.md5sum] = "9762dabdde37a804072bccbfd311d357"
+SRC_URI[archive.sha256sum] = "af2ebdf7f74e6580c4f1a12bdfe26b9ff90374d7acae061de0666d64012a9db2"
SRC_URI += " \
file://0001-Add-format-attribute-to-_synctex_malloc.patch \
file://0002-add-a-formatting-attribute-check.patch \
"
-EXTRA_OECONF = " \
- --enable-thumbnailer \
- --without-systemduserunitdir \
+GTKDOC_MESON_OPTION = "gtk_doc"
+
+EXTRA_OEMESON = " \
+ -Dsystemduserunitdir=no \
"
do_compile_prepend() {
@@ -35,8 +38,8 @@ do_compile_prepend() {
}
PACKAGECONFIG ??= ""
-PACKAGECONFIG[nautilus] = "--enable-nautilus,--disable-nautilus,nautilus"
-PACKAGECONFIG[browser-plugin] = "--enable-browser-plugin,--disable-browser-plugin,"
+PACKAGECONFIG[nautilus] = "-Dnautilus=true,-Dnautilus=false,nautilus"
+PACKAGECONFIG[browser-plugin] = "-Dbrowser_plugin=true,-Dbrowser_plugin=false"
RDEPENDS_${PN} += "glib-2.0-utils"
RRECOMMMENDS_${PN} = "adwaita-icon-theme"