aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-dvb/tvheadend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-dvb/tvheadend')
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch16
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-allocate-space-for-buf-on-heap.patch46
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb16
3 files changed, 19 insertions, 59 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch
index 59bd4ef08f..c6e20b75e8 100644
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch
@@ -33,12 +33,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
}
--- a/src/epggrab/module/psip.c
+++ b/src/epggrab/module/psip.c
-@@ -383,14 +383,14 @@ _psip_eit_callback_channel
+@@ -223,14 +223,14 @@ _psip_eit_callback_channel
- tvhtrace(LS_PSIP, " %03d: [%s] eventid 0x%04x at %"PRItime_t", duration %d, title: '%s' (%d bytes)",
+ tvhtrace(LS_PSIP, " %03d: [%s] eventid 0x%04x at %"PRItime_t", duration %d, etmlocation %x, title: '%s' (%d bytes)",
i, ch ? channel_get_name(ch, channel_blank_name) : "(null)",
-- eventid, start, length,
-+ eventid, (intmax_t)start, length,
+- eventid, start, length, etmlocation,
++ eventid, (intmax_t)start, length, etmlocation,
lang_str_get(title, NULL), titlelen);
save2 = changes2 = 0;
@@ -146,12 +146,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
/* Failed */
--- a/src/epggrab/module/opentv.c
+++ b/src/epggrab/module/opentv.c
-@@ -486,7 +486,7 @@ opentv_parse_event_section_one
+@@ -497,7 +497,7 @@ opentv_parse_event_section_one
1, &save, &changes);
tvhdebug(LS_OPENTV, "find by time start %"PRItime_t " stop "
- "%"PRItime_t " eid %d = %p",
-- ev.start, ev.stop, ev.eid, ebc);
-+ (intmax_t)ev.start, (intmax_t)ev.stop, ev.eid, ebc);
+ "%"PRItime_t " ch %"PRId64" eid %d = %p",
+- ev.start, ev.stop, ch->ch_number, ev.eid, ebc);
++ (intmax_t)ev.start, (intmax_t)ev.stop, ch->ch_number, ev.eid, ebc);
save |= epg_broadcast_set_dvb_eid(ebc, ev.eid, &changes);
} else {
ebc = epg_broadcast_find_by_eid(ch, ev.eid);
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-allocate-space-for-buf-on-heap.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-allocate-space-for-buf-on-heap.patch
deleted file mode 100644
index cbd76b6abf..0000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-allocate-space-for-buf-on-heap.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From d4a405f87fc215c14e610a25b5a6b14060c1ef15 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 25 Dec 2019 13:53:52 -0800
-Subject: [PATCH] allocate space for buf on heap
-
-Avoids
-| src/epggrab/module/xmltv.c:204:47: error: '%s' directive output may be truncated writing between 2 and 2147483645 bytes into a region of size 115 [-Werror=format-truncation=]
-| 204 | snprintf(buf, sizeof(buf)-1, "ddprogid://%s/%s", mod->id, s);
-| | ^~
-
-Upstream-Status: Submitted [https://github.com/tvheadend/tvheadend/pull/1324]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/epggrab/module/xmltv.c | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/epggrab/module/xmltv.c b/src/epggrab/module/xmltv.c
-index 34ab05bdb..b1a956614 100644
---- a/src/epggrab/module/xmltv.c
-+++ b/src/epggrab/module/xmltv.c
-@@ -197,11 +197,12 @@ static void parse_xmltv_dd_progid
- (epggrab_module_t *mod, const char *s, char **uri, char **suri,
- epg_episode_num_t *epnum)
- {
-- char buf[128];
- if (strlen(s) < 2) return;
-
-+ char* buf = (char *)malloc(strlen(s) + strlen(mod->id) + 13);
-+ buf[strlen(s) + strlen(mod->id) + 12] = '\0';
- /* Raw URI */
-- snprintf(buf, sizeof(buf)-1, "ddprogid://%s/%s", mod->id, s);
-+ snprintf(buf, strlen(s) + strlen(mod->id) + 12, "ddprogid://%s/%s", mod->id, s);
-
- /* SH - series without episode id so ignore */
- if (strncmp("SH", s, 2))
-@@ -219,6 +220,7 @@ static void parse_xmltv_dd_progid
- if (buf[e+1]) sscanf(&buf[e+1], "%hu", &(epnum->e_num));
- }
- }
-+ free(buf);
- }
-
- /**
---
-2.24.1
-
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
index 20faef047e..2d79777001 100644
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
@@ -5,16 +5,15 @@ inherit autotools-brokensep gettext gitpkgv pkgconfig
DEPENDS = "avahi cmake-native dvb-apps libdvbcsa libpcre2 openssl uriparser zlib"
-LICENSE = "GPLv3+"
+LICENSE = "GPL-3.0-or-later"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9cae5acac2e9ee2fc3aec01ac88ce5db"
-SRC_URI = "git://github.com/tvheadend/tvheadend.git \
+SRC_URI = "git://github.com/tvheadend/tvheadend.git;branch=master;protocol=https \
file://0001-adjust-for-64bit-time_t.patch \
- file://0001-allocate-space-for-buf-on-heap.patch \
"
-SRCREV = "fda89e85e0b6ae796d8a09e178d3937aa7869270"
-PV = "4.3+git${SRCPV}"
+SRCREV = "cc602833684953fc3e6f1c89d4f08f6dfef179e3"
+PV = "4.3+git"
PKGV = "4.3+git${GITPKGV}"
S = "${WORKDIR}/git"
@@ -24,7 +23,14 @@ EXTRA_OECONF += "--arch=${TARGET_ARCH} \
--disable-ffmpeg_static \
--disable-libav \
--python=python3 \
+ --disable-dvbscan \
"
+EXTRA_OECONF:append:libc-musl = " --disable-execinfo"
+
+EXTRA_OEMAKE = "CFLAGS_NO_WERROR=yes"
CLEANBROKEN = "1"
+do_configure:append() {
+ sed -i -e "s|${WORKDIR}|<TOPDIR>|g" ${B}/build.linux/build.c
+}