aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/nanomsg/nng_1.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/nanomsg/nng_1.7.3.bb')
-rw-r--r--meta-networking/recipes-connectivity/nanomsg/nng_1.7.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/nanomsg/nng_1.7.3.bb b/meta-networking/recipes-connectivity/nanomsg/nng_1.7.3.bb
new file mode 100644
index 0000000000..a6556249b7
--- /dev/null
+++ b/meta-networking/recipes-connectivity/nanomsg/nng_1.7.3.bb
@@ -0,0 +1,22 @@
+SUMMARY = "nanomsg-next-generation -- light-weight brokerless messaging"
+DESCRIPTION = "NNG, like its predecessors nanomsg (and to some extent ZeroMQ), is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery."
+HOMEPAGE = "https://github.com/nanomsg/nng"
+SECTION = "libs/networking"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a41e579bb4326c21c774f8e51e41d8a3"
+
+SRC_URI = "git://github.com/nanomsg/nng.git;branch=master;protocol=https"
+SRCREV = "85fbe7f9e4642b554d0d97f2e3ff2aa12978691a"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON -DNNG_ENABLE_NNGCAT=ON"
+
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[mbedtls] = "-DNNG_ENABLE_TLS=ON,-DNNG_ENABLE_TLS=OFF,mbedtls"
+
+PACKAGES =+ "${PN}-tools"
+FILES:${PN}-tools = "${bindir}/*"