aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gensio/gensio_2.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/gensio/gensio_2.8.4.bb')
-rw-r--r--meta-oe/recipes-connectivity/gensio/gensio_2.8.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gensio/gensio_2.8.4.bb b/meta-oe/recipes-connectivity/gensio/gensio_2.8.4.bb
new file mode 100644
index 0000000000..1f85c46e2f
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gensio/gensio_2.8.4.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
+HOMEPAGE = "https://github.com/cminyard/gensio"
+LICENSE = "GPL-2.0-only & LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ "
+
+SRCREV = "300644fc02b7099ca27ca5bac88c47e159ba8a6b"
+
+SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+PACKAGECONFIG ??= "openssl tcp-wrappers"
+
+PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
+PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
+PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
+
+EXTRA_OECONF = "--without-python"
+
+RDEPENDS:${PN} += "bash"
+
+FILES:${PN}-staticdev += "${libexecdir}/gensio/${PV}/libgensio_*.a"