aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/opencl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/opencl')
-rw-r--r--meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb (renamed from meta-oe/recipes-core/opencl/ocl-icd_2.3.1.bb)4
-rw-r--r--meta-oe/recipes-core/opencl/opencl-clhpp_git.bb2
-rw-r--r--meta-oe/recipes-core/opencl/opencl-headers_2023.12.14.bb (renamed from meta-oe/recipes-core/opencl/opencl-headers_git.bb)4
-rw-r--r--meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb (renamed from meta-oe/recipes-core/opencl/opencl-icd-loader_git.bb)11
4 files changed, 12 insertions, 9 deletions
diff --git a/meta-oe/recipes-core/opencl/ocl-icd_2.3.1.bb b/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
index 250cb6883b..d43ea281ae 100644
--- a/meta-oe/recipes-core/opencl/ocl-icd_2.3.1.bb
+++ b/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
@@ -7,12 +7,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1238d5bccbb6bda30654e48dcc0a554b"
SRC_URI = "git://github.com/OCL-dev/ocl-icd.git;protocol=https;branch=master"
-SRCREV = "1165deedb2ae741cd76e60986f7c2cb5023059d9"
+SRCREV = "fdde6677b21329432db8b481e2637cd10f7d3cb2"
S = "${WORKDIR}/git"
inherit autotools
DEPENDS = "ruby-native"
+PROVIDES = "virtual/opencl-icd"
+RPROVIDES:${PN} = "virtual-opencl-icd"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb b/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
index 8a712602cc..7ae0362d37 100644
--- a/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
+++ b/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
@@ -6,7 +6,7 @@ SRC_URI = "git://github.com/KhronosGroup/OpenCL-CLHPP.git;protocol=https;branch=
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PV = "2.0.16+git${SRCPV}"
+PV = "2.0.16+git"
SRCREV = "1df82b9749739f2681081092ae163bb0f0d40f66"
S = "${WORKDIR}/git"
diff --git a/meta-oe/recipes-core/opencl/opencl-headers_git.bb b/meta-oe/recipes-core/opencl/opencl-headers_2023.12.14.bb
index 8ad7d9d10b..8b1c795666 100644
--- a/meta-oe/recipes-core/opencl/opencl-headers_git.bb
+++ b/meta-oe/recipes-core/opencl/opencl-headers_2023.12.14.bb
@@ -5,8 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SECTION = "base"
S = "${WORKDIR}/git"
-PV = "2022.09.23"
-SRCREV = "5e2f8c66476bcf60eb8c2921807e34efb30294ee"
+SRCREV = "2368105c0531069fe927989505de7d125ec58c55"
SRC_URI = "git://github.com/KhronosGroup/OpenCL-Headers.git;branch=main;protocol=https"
do_configure[noexec] = "1"
@@ -17,3 +16,4 @@ do_install () {
install -d ${D}${includedir}/CL/
install -m 0644 ${S}/CL/*.h ${D}${includedir}/CL
}
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-core/opencl/opencl-icd-loader_git.bb b/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
index 67437732d8..146ec6e472 100644
--- a/meta-oe/recipes-core/opencl/opencl-icd-loader_git.bb
+++ b/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
@@ -9,10 +9,11 @@ inherit pkgconfig cmake
DEPENDS += "opencl-headers"
PROVIDES = "virtual/opencl-icd"
+RPROVIDES:${PN} = "virtual-opencl-icd"
S = "${WORKDIR}/git"
-PV = "v2022.01.04+git${SRCPV}"
-SRCREV = "169f05d026e65948b30cfe2200595fda92198cf7"
+
+SRCREV = "229410f86a8c8c9e0f86f195409e5481a2bae067"
SRC_URI = "git://github.com/KhronosGroup/OpenCL-ICD-Loader.git;branch=main;protocol=https"
EXTRA_OECMAKE:append = " \
@@ -21,11 +22,11 @@ EXTRA_OECMAKE:append = " \
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${B}/test/loader_test/icd_loader_test ${D}${bindir}/
+ install -m 0755 ${B}/icd_loader_test ${D}${bindir}/
chrpath -d ${D}${bindir}/icd_loader_test
install -d ${D}${libdir}
- install -m 0644 ${B}/test/log/libIcdLog.so ${D}${libdir}/
- install -m 0644 ${B}/test/driver_stub/libOpenCLDriverStub.so ${D}${libdir}/
+ install -m 0644 ${B}/libIcdLog.so ${D}${libdir}/
+ install -m 0644 ${B}/libOpenCLDriverStub.so ${D}${libdir}/
chrpath -d ${D}${libdir}/libOpenCLDriverStub.so
install -m 0644 ${B}/libOpenCL.so.1.2 ${D}${libdir}/
cd ${D}${libdir}