aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend')
-rw-r--r--meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
new file mode 100644
index 0000000000..b914405b7e
--- /dev/null
+++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+PRINC = "1"
+
+SRC_URI += "file://lighttpd.service"
+
+do_install_append() {
+ install -d ${D}${base_libdir}/systemd/systemd/
+ install -m 0644 ${WORKDIR}/lighttpd.service ${D}${base_libdir}/systemd/systemd/
+
+ install -d ${D}${base_libdir}/systemd/systemd/multi-user.target.wants
+ ln -sf ../lighttpd.service ${D}${base_libdir}/systemd/systemd/multi-user.target.wants
+}
+
+FILES_${PN} += "${base_libdir}/systemd"
+