aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/socketcan/can-isotp_git.bb')
-rw-r--r--meta-oe/recipes-extended/socketcan/can-isotp_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/socketcan/can-isotp_git.bb b/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
index eca8dfc7b7..ab97356e9b 100644
--- a/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
+++ b/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
@@ -1,9 +1,10 @@
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=72d977d697c3c05830fdff00a7448931"
-SRCREV = "b31bce98d65f894aad6427bcf6f3f7822e261a59"
-PV = "1.0+git${SRCPV}"
+SRCREV = "7626d0a0707391970080d493ce69638719938da7"
+PV = "1.0+git"
+
+SRC_URI = "git://github.com/hartkopp/can-isotp.git;protocol=https;branch=master"
-SRC_URI = "git://github.com/hartkopp/can-isotp.git;protocol=https"
S = "${WORKDIR}/git"
@@ -11,4 +12,8 @@ inherit module
EXTRA_OEMAKE += "KERNELDIR=${STAGING_KERNEL_DIR}"
-PNBLACKLIST[can-isotp] ?= "Kernel module Needs forward porting to kernel 5.2+"
+do_install:append() {
+ install -Dm 644 ${S}/include/uapi/linux/can/isotp.h ${D}${includedir}/linux/can/isotp.h
+}
+
+SKIP_RECIPE[can-isotp] ?= "Not needed with kernel 5.10+"