aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/libbpf/libbpf_1.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/libbpf/libbpf_1.4.0.bb')
-rw-r--r--meta-oe/recipes-kernel/libbpf/libbpf_1.4.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/libbpf/libbpf_1.4.0.bb b/meta-oe/recipes-kernel/libbpf/libbpf_1.4.0.bb
new file mode 100644
index 0000000000..f2ec48f390
--- /dev/null
+++ b/meta-oe/recipes-kernel/libbpf/libbpf_1.4.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Library for BPF handling"
+DESCRIPTION = "Library for BPF handling"
+HOMEPAGE = "https://github.com/libbpf/libbpf"
+SECTION = "libs"
+LICENSE = "LGPL-2.1-or-later"
+
+LIC_FILES_CHKSUM = "file://../LICENSE.LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
+
+DEPENDS = "zlib elfutils"
+
+SRC_URI = "git://github.com/libbpf/libbpf.git;protocol=https;branch=master"
+SRCREV = "20ea95b4505c477af3b6ff6ce9d19cee868ddc5d"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64|riscv64|powerpc|powerpc64|mips64).*-linux"
+
+S = "${WORKDIR}/git/src"
+
+EXTRA_OEMAKE += "DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+EXTRA_OEMAKE:append:class-native = " UAPIDIR=${includedir}"
+
+inherit pkgconfig
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install
+}
+
+do_install:append:class-native() {
+ oe_runmake install_uapi_headers
+}
+
+BBCLASSEXTEND = "native nativesdk"