aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb1
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch44
-rw-r--r--meta-oe/recipes-multimedia/libass/libass_0.17.2.bb (renamed from meta-oe/recipes-multimedia/libass/libass_0.17.1.bb)4
-rw-r--r--meta-oe/recipes-multimedia/live555/live555_20210824.bb2
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch8
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_1.14.1.bb (renamed from meta-oe/recipes-multimedia/webm/libvpx_1.14.0.bb)2
6 files changed, 53 insertions, 8 deletions
diff --git a/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb b/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
index 9fd91114d7..bbce3e3bfd 100644
--- a/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
+++ b/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
@@ -13,6 +13,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
file://0001-genisoimage-Add-missing-extern-definition.patch \
file://0001-add-new-option-eltorito-platform.patch \
file://0001-genisoimage-Add-checksum.h-and-md5.h-for-function-pr.patch \
+ file://fix-incompatible-pointer-type-error.patch \
"
SRC_URI:append:class-nativesdk = " \
file://0001-install-netscsid-to-bin-for-nativesdk.patch \
diff --git a/meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch b/meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch
new file mode 100644
index 0000000000..887a54f7f2
--- /dev/null
+++ b/meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch
@@ -0,0 +1,44 @@
+Fix incompatible pointer type error when gcc option '-Wincompatible-pointer-types' set:
+
+cdrkit-1.1.11/genisoimage/eltorito.c:399:41: error: passing argument 1 of 'set_721' from incompatible pointer type [-Wincompatible-pointer-types]
+ 399 | set_721(&last_section_header->entry_count, nentries);
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ | |
+ | char (*)[2]
+In file included from cdrkit/1.1.11/cdrkit-1.1.11/genisoimage/eltorito.c:39:
+cdrkit-1.1.11/genisoimage/genisoimage.h:507:21: note: expected 'char *' but argument is of type 'char (*)[2]'
+ 507 | extern void set_721(char *, unsigned int);
+ | ^~~~~~
+
+Upstream-Status: Inactive-Upstream [lastrelease: 2010]
+
+[1]: https://en.wikipedia.org/wiki/Cdrkit
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+---
+ genisoimage/eltorito.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/genisoimage/eltorito.c b/genisoimage/eltorito.c
+index a804988..e48d58c 100644
+--- a/genisoimage/eltorito.c
++++ b/genisoimage/eltorito.c
+@@ -396,7 +396,7 @@ get_torito_desc(struct eltorito_boot_descriptor *boot_desc)
+ (arch != newarch) ||
+ (current_boot_entry->type & ELTORITO_SECTION_HEADER)) {
+ if (last_section_header)
+- set_721(&last_section_header->entry_count, nentries);
++ set_721((char *)(&last_section_header->entry_count), nentries);
+ nentries = 1;
+ last_section_header = (struct eltorito_sectionheader_entry *)
+ (de2->table + offset);
+@@ -419,7 +419,7 @@ get_torito_desc(struct eltorito_boot_descriptor *boot_desc)
+ }
+
+ if (last_section_header) {
+- set_721(&last_section_header->entry_count, nentries);
++ set_721((char *)(&last_section_header->entry_count), nentries);
+ last_section_header->header_id[0] = EL_TORITO_SHDR_ID_LAST_SHDR;
+ }
+
diff --git a/meta-oe/recipes-multimedia/libass/libass_0.17.1.bb b/meta-oe/recipes-multimedia/libass/libass_0.17.2.bb
index 800ad1b15e..e239d028eb 100644
--- a/meta-oe/recipes-multimedia/libass/libass_0.17.1.bb
+++ b/meta-oe/recipes-multimedia/libass/libass_0.17.2.bb
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a42532a0684420bdb15556c3cdd49a75"
DEPENDS = "fontconfig freetype fribidi harfbuzz"
-SRC_URI = "git://github.com/libass/libass.git;protocol=https;branch=0.17.1-branch"
-SRCREV = "e8ad72accd3a84268275a9385beb701c9284e5b3"
+SRC_URI = "git://github.com/libass/libass.git;protocol=https;branch=master"
+SRCREV = "cbb48cc4f2f076300004b8b06a86bec55281d0c2"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
diff --git a/meta-oe/recipes-multimedia/live555/live555_20210824.bb b/meta-oe/recipes-multimedia/live555/live555_20210824.bb
index a899049b77..80c770c3e3 100644
--- a/meta-oe/recipes-multimedia/live555/live555_20210824.bb
+++ b/meta-oe/recipes-multimedia/live555/live555_20210824.bb
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure() {
- cp ${WORKDIR}/config.linux-cross .
+ cp ${UNPACKDIR}/config.linux-cross .
echo "COMPILE_OPTS+=" -fPIC -DXLOCALE_NOT_USED"" >> config.linux-cross
./genMakefiles linux-cross
}
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch b/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
index 463651aa4a..bd3d697885 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
+++ b/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
@@ -1,4 +1,4 @@
-From 2829e6998b7595dd2108c1497fdd02485ef99e2c Mon Sep 17 00:00:00 2001
+From 1bbbf27a23c91dcc271b773a97153063461b986d Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Tue, 16 Aug 2011 16:04:35 +0200
Subject: [PATCH] Upstream: not yet
@@ -11,10 +11,10 @@ Upstream-Status: Pending
1 file changed, 16 insertions(+), 4 deletions(-)
diff --git a/build/make/configure.sh b/build/make/configure.sh
-index b645a666f..0b99a8b38 100644
+index 93643f3de..e84198200 100644
--- a/build/make/configure.sh
+++ b/build/make/configure.sh
-@@ -658,6 +658,8 @@ process_common_cmdline() {
+@@ -692,6 +692,8 @@ process_common_cmdline() {
;;
--prefix=*)
prefix="${optval}"
@@ -23,7 +23,7 @@ index b645a666f..0b99a8b38 100644
;;
--libdir=*)
libdir="${optval}"
-@@ -687,13 +689,23 @@ process_cmdline() {
+@@ -721,13 +723,23 @@ process_cmdline() {
}
post_process_common_cmdline() {
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.14.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.14.1.bb
index b4d49842ea..f32c7842c3 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx_1.14.0.bb
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.14.1.bb
@@ -7,7 +7,7 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
-SRCREV = "602e2e8979d111b02c959470da5322797dd96a19"
+SRCREV = "12f3a2ac603e8f10742105519e0cd03c3b8f71dd"
SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https;branch=main \
file://libvpx-configure-support-blank-prefix.patch \
"