aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/crucible/crucible_2023.11.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/crucible/crucible_2023.11.02.bb')
-rw-r--r--meta-oe/recipes-support/crucible/crucible_2023.11.02.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/crucible/crucible_2023.11.02.bb b/meta-oe/recipes-support/crucible/crucible_2023.11.02.bb
new file mode 100644
index 0000000000..d53e1a276b
--- /dev/null
+++ b/meta-oe/recipes-support/crucible/crucible_2023.11.02.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=201414b6610203caed355323b1ab3116"
+
+GO_IMPORT = "github.com/usbarmory/crucible"
+SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
+
+GO_INSTALL = "\
+ ${GO_IMPORT}/cmd/crucible \
+ ${GO_IMPORT}/cmd/habtool \
+"
+SRCREV = "dec27cd4e0e0db106c0a21d429c04ca8d36bbdd5"
+
+export GOPROXY = "https://proxy.golang.org,direct"
+# Workaround for network access issue during compile step.
+# This needs to be fixed in the recipes buildsystem so that
+# it can be accomplished during do_fetch task.
+do_compile[network] = "1"
+
+inherit go-mod