aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/read-edid
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/read-edid')
-rw-r--r--meta-oe/recipes-support/read-edid/read-edid/0001-get-edid-define-quiet-once.patch44
-rw-r--r--meta-oe/recipes-support/read-edid/read-edid_3.0.2.bb2
2 files changed, 45 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/read-edid/read-edid/0001-get-edid-define-quiet-once.patch b/meta-oe/recipes-support/read-edid/read-edid/0001-get-edid-define-quiet-once.patch
new file mode 100644
index 0000000000..5147f17c3a
--- /dev/null
+++ b/meta-oe/recipes-support/read-edid/read-edid/0001-get-edid-define-quiet-once.patch
@@ -0,0 +1,44 @@
+From 9da8eb6663d0ba046bc0570172c549d421de043a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 23:39:32 -0700
+Subject: [PATCH] get-edid: define quiet once
+
+Fixes build with gcc 10
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ get-edid/classic.c | 2 +-
+ get-edid/i2c.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/get-edid/classic.c b/get-edid/classic.c
+index 9cc8ee3..b13f5f0 100644
+--- a/get-edid/classic.c
++++ b/get-edid/classic.c
+@@ -26,7 +26,7 @@ typedef byte* real_ptr;
+ #define dosmemput(buffer,length,offset) memcpy(offset,buffer,length)
+
+ #define display(...) if (quiet == 0) { fprintf(stderr, __VA_ARGS__); }
+-int quiet;
++extern int quiet;
+
+ real_ptr far_ptr_to_real_ptr( uint32 farptr )
+ {
+diff --git a/get-edid/i2c.c b/get-edid/i2c.c
+index 625d7cb..0929e98 100644
+--- a/get-edid/i2c.c
++++ b/get-edid/i2c.c
+@@ -15,7 +15,7 @@
+
+ //Ideas (but not too much actual code) taken from i2c-tools. Thanks guys.
+
+-int quiet;
++extern int quiet;
+
+ #define display(...) if (quiet == 0) { fprintf(stderr, __VA_ARGS__); }
+
+--
+2.28.0
+
diff --git a/meta-oe/recipes-support/read-edid/read-edid_3.0.2.bb b/meta-oe/recipes-support/read-edid/read-edid_3.0.2.bb
index e4c2cadc2d..28da51a21c 100644
--- a/meta-oe/recipes-support/read-edid/read-edid_3.0.2.bb
+++ b/meta-oe/recipes-support/read-edid/read-edid_3.0.2.bb
@@ -3,7 +3,6 @@ DESCRIPTION = "read-edid is a set of two tools - get-edid, which gets the raw \
EDID information from the monitor, and parse-edid, which turns \
the raw binary information into a xorg.conf-compatible monitor \
section."
-AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
HOMEPAGE = "http://www.polypux.org/projects/read-edid/"
SECTION = "console/utils"
LICENSE = "read-edid"
@@ -11,6 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=292c42e2aedc4af636636bf7af0e2b26"
SRC_URI = "http://polypux.org/projects/read-edid/read-edid-${PV}.tar.gz \
file://0001-Do-not-install-license-file.patch \
+ file://0001-get-edid-define-quiet-once.patch \
"
SRC_URI[md5sum] = "016546e438bf6c98739ff74061df9854"
SRC_URI[sha256sum] = "c7c6d8440f5b90f98e276829271ccea5b2ff5a3413df8a0f87ec09f834af186f"