aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/rtkit/rtkit_0.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/rtkit/rtkit_0.13.bb')
-rw-r--r--meta-oe/recipes-support/rtkit/rtkit_0.13.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/rtkit/rtkit_0.13.bb b/meta-oe/recipes-support/rtkit/rtkit_0.13.bb
new file mode 100644
index 0000000000..4f06e55e8e
--- /dev/null
+++ b/meta-oe/recipes-support/rtkit/rtkit_0.13.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "REALTIMEKIT Realtime Policy and Watchdog Daemon"
+LICENSE = "GPL-3.0-only & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a8e768468b658b3ed44971b53d4a6716"
+
+SRC_URI = "git://github.com/heftig/rtkit.git;protocol=https;branch=master"
+
+SRCREV = "b9169402fe5e82d20efb754509eb0b191f214599"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig features_check useradd
+
+REQUIRED_DISTRO_FEATURES = "polkit"
+
+DEPENDS = "dbus libcap polkit xxd-native"
+
+PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[systemd] = ",,systemd"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = "--system --no-create-home --user-group --shell /bin/nologin rtkit"
+
+FILES:${PN} += "${libdir} ${datadir} ${systemd_system_unitdir}"
+