aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-alembic_1.13.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-alembic_1.13.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.13.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.13.1.bb b/meta-python/recipes-devtools/python/python3-alembic_1.13.1.bb
new file mode 100644
index 0000000000..c4853c4437
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.13.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A database migration tool for SQLAlchemy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3023b042cb6002cb398344b51c67093"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "4932c8558bf68f2ee92b9bbcb8218671c627064d5b08939437af6d77dc05e595"
+
+PYPI_PACKAGE = "alembic"
+
+RDEPENDS:${PN} += "\
+ python3-dateutil \
+ python3-editor \
+ python3-mako \
+ python3-sqlalchemy \
+ python3-misc \
+"
+
+BBCLASSEXTEND = "native nativesdk"