aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
new file mode 100644
index 0000000000..5c6f4e2356
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "A port of Ruby on Rails' inflection to Python."
+HOMEPAGE = "https://pypi.org/project/inflection"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31"
+
+SRC_URI[md5sum] = "c3287d4f0e3bdf625a52d655cc514403"
+SRC_URI[sha256sum] = "1a29730d366e996aaacffb2f1f1cb9593dc38e2ddd30c91250c6dde09ea9b417"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI +=" \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest +=" \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/
+}
+
+
+RDEPENDS:${PN} += "python3-pytest"
+
+BBCLASSEXTEND = "native nativesdk"