aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb b/meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb
new file mode 100644
index 0000000000..534ff90666
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
+HOMEPAGE = "https://github.com/python/mypy"
+LICENSE = "MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "3d087fcbec056c4ee34974da493a826ce316947485cef3901f511848e687c131"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += " \
+ python3-mypy-extensions-native \
+ python3-types-psutil-native \
+ python3-types-setuptools-native \
+ python3-typing-extensions-native \
+"
+
+RDEPENDS:${PN} += " \
+ python3-modules \
+ python3-mypy-extensions \
+ python3-typing-extensions \
+"