aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pint_0.19.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.19.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.19.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.19.2.bb b/meta-python/recipes-devtools/python/python3-pint_0.19.2.bb
new file mode 100644
index 0000000000..06337edb62
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.19.2.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Physical quantities Python module"
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi ptest python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "e1d4989ff510b378dad64f91711e7bdabe5ca78d75b06a18569ac454678c4baf"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-packaging \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}