aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb24
1 files changed, 13 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb b/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
index 607c719461..4abec0a01c 100644
--- a/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
@@ -8,17 +8,17 @@ SRCNAME = "ptyprocess"
SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
-inherit pypi setuptools3
+inherit pypi python_flit_core
UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-RDEPENDS_${PN} = "\
- ${PYTHON_PN}-core \
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-terminal \
- ${PYTHON_PN}-resource \
+RDEPENDS:${PN} = "\
+ python3-core \
+ python3-fcntl \
+ python3-terminal \
+ python3-resource \
"
BBCLASSEXTEND = "native nativesdk"
@@ -29,11 +29,13 @@ SRC_URI += " \
file://run-ptest \
"
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-terminal \
- ${PYTHON_PN}-resource \
+RDEPENDS:${PN}-ptest += " \
+ bash \
+ python3-fcntl \
+ python3-pytest \
+ python3-resource \
+ python3-terminal \
+ python3-unittest-automake-output \
"
do_install_ptest() {