aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests-futures_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests-futures_1.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-futures_1.0.1.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-futures_1.0.1.bb b/meta-python/recipes-devtools/python/python3-requests-futures_1.0.1.bb
new file mode 100644
index 0000000000..28f034f7e3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests-futures_1.0.1.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Small add-on for the python requests http library. Makes use of python 3.2’s concurrent.futures or the backport for prior versions of python."
+HOMEPAGE = "https://github.com/ross/requests-futures"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e1e50798d0afe0e1f87594c6619a2fa5"
+
+SRC_URI[sha256sum] = "f55a4ef80070e2858e7d1e73123d2bfaeaf25b93fd34384d8ddf148e2b676373"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-requests \
+"
+