aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb b/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb
new file mode 100644
index 0000000000..a80f6c2db2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
+HOMEPAGE = "https://github.com/sissaschool/xmlschema"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=26aa26eda991a3a2b61c11b62d3fda65"
+
+SRC_URI[sha256sum] = "2066ecbc9728112073f6f44d17c5c16723aff1c7d22a7c4c6421e2d68ec5f0ea"
+
+PYPI_PACKAGE = "xmlschema"
+inherit pypi setuptools3
+
+DEPENDS += "\
+ python3-elementpath-native \
+"
+
+RDEPENDS:${PN} += "\
+ python3-elementpath \
+ python3-modules \
+"
+
+BBCLASSEXTEND = "native nativesdk"