aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb')
-rw-r--r--meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb
new file mode 100644
index 0000000000..5949a55fa8
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "PyEphem astronomical calculations"
+HOMEPAGE = "http://rhodesmill.org/pyephem/"
+
+LICENSE = "LGPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f288303760f6e5ceaafe3aaa32186ab1"
+
+SRC_URI[sha256sum] = "36b51a8dc7cfdeb456dd6b8ab811accab8341b2d562ee3c6f4c86f6d3dbb984e"
+
+PYPI_PACKAGE = "ephem"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-math \
+ "