aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb6
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb4
-rw-r--r--meta-python/recipes-extended/python-cson/python3-cson_git.bb4
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh_0.50.bb2
-rw-r--r--meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb2
-rw-r--r--meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb4
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb4
-rw-r--r--meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb4
-rw-r--r--meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb2
9 files changed, 16 insertions, 16 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
index 2b5b253b5d..204793759d 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
@@ -30,17 +30,17 @@ REQUIRED_DISTRO_FEATURES = "systemd"
inherit setuptools3 python3native
-RDEPENDS_${PN} += "python3-pykickstart python3-pyudev \
+RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
parted python3-pyparted multipath-tools \
lsof cryptsetup libblockdev \
libbytesize \
"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/dbus-1/system-services \
"
inherit systemd
SYSTEMD_AUTO_ENABLE = "disable"
-SYSTEMD_SERVICE_${PN} = "blivet.service"
+SYSTEMD_SERVICE:${PN} = "blivet.service"
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
index 92402bee56..4f5856d1b2 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
@@ -18,11 +18,11 @@ REQUIRED_DISTRO_FEATURES = "x11 systemd"
inherit setuptools3 python3native
-RDEPENDS_${PN} = "python3-pygobject python3 \
+RDEPENDS:${PN} = "python3-pygobject python3 \
python3-blivet gtk+3 \
python3-pid libreport \
"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/* \
"
diff --git a/meta-python/recipes-extended/python-cson/python3-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index 5c74c7a307..7bc61f06d7 100644
--- a/meta-python/recipes-extended/python-cson/python3-cson_git.bb
+++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -12,8 +12,8 @@ SRC_URI = "git://github.com/gt3389b/python-cson.git"
S = "${WORKDIR}/git"
-RDEPENDS_${PN}_class-native = ""
-DEPENDS_append_class-native = " python-native "
+RDEPENDS:${PN}:class-native = ""
+DEPENDS:append:class-native = " python-native "
inherit setuptools3
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb
index 64a24ade3e..372b3a006f 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb
@@ -13,5 +13,5 @@ SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=mas
"
SRCREV = "11980776c5ad757401ea1d12fd1f331d96428105"
-FILES_${PN} += "${datadir}/*"
+FILES:${PN} += "${datadir}/*"
diff --git a/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb
index 5949a55fa8..7cf88ec332 100644
--- a/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb
+++ b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb
@@ -10,7 +10,7 @@ PYPI_PACKAGE = "ephem"
inherit pypi setuptools3
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-math \
"
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb
index 62d2729dc8..829ada4f8b 100644
--- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb
+++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb
@@ -3,10 +3,10 @@ HOMEPAGE = "http://fedoraproject.org/wiki/pykickstart"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
DEPENDS = "python3"
-RDEPENDS_${PN} = "python3 \
+RDEPENDS:${PN} = "python3 \
python3-requests \
python3-six \
"
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb
index 8909aa11f4..765201ca7b 100644
--- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb
+++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb
@@ -16,10 +16,10 @@ inherit pypi distutils3
DEPENDS += "parted"
-RDEPENDS_${PN}_class-target += " \
+RDEPENDS:${PN}:class-target += " \
parted (>= 2.3) \
python3-stringold python3-codecs python3-math \
"
-RDEPENDS_${PN}_class-native = ""
+RDEPENDS:${PN}:class-native = ""
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
index 988dae1335..a6ca4d5f83 100644
--- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
+++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
@@ -27,7 +27,7 @@ DEPENDS += " \
${PYTHON_PN}-wheel-native \
"
-RDEPENDS_${PN}_class-target += "\
+RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
${PYTHON_PN}-netclient \
@@ -43,7 +43,7 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-yamlloader \
"
-ALTERNATIVE_${PN} = "mof_compiler"
+ALTERNATIVE:${PN} = "mof_compiler"
ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
ALTERNATIVE_PRIORITY = "60"
diff --git a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb
index b06fee5500..46b6a99605 100644
--- a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb
+++ b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb
@@ -15,7 +15,7 @@ DEPENDS += " \
${PYTHON_PN}-click-native \
"
-RDEPENDS_${PN}_class-target += "\
+RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-ply \
${PYTHON_PN}-pyyaml \
${PYTHON_PN}-six \