aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc10
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-sqlalchemy_2.4.1.bb12
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc b/meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc
deleted file mode 100644
index 86ba9dda56..0000000000
--- a/meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "Adds SQLAlchemy support to your Flask application."
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
-
-SRC_URI[md5sum] = "1f5781cf3e1a2b1aabda47a5b20d2073"
-SRC_URI[sha256sum] = "6974785d913666587949f7c2946f7001e4fa2cb2d19f4e69ead02e4b8f50b33d"
-
-PYPI_PACKAGE = "Flask-SQLAlchemy"
-
-RDEPENDS_${PN} = "${PYTHON_PN}-sqlalchemy ${PYTHON_PN}-flask"
diff --git a/meta-python/recipes-devtools/python/python3-flask-sqlalchemy_2.4.1.bb b/meta-python/recipes-devtools/python/python3-flask-sqlalchemy_2.4.1.bb
index 07f45bcfff..2c6110d0bd 100644
--- a/meta-python/recipes-devtools/python/python3-flask-sqlalchemy_2.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-sqlalchemy_2.4.1.bb
@@ -1,2 +1,12 @@
+DESCRIPTION = "Adds SQLAlchemy support to your Flask application."
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
+
+SRC_URI[md5sum] = "1f5781cf3e1a2b1aabda47a5b20d2073"
+SRC_URI[sha256sum] = "6974785d913666587949f7c2946f7001e4fa2cb2d19f4e69ead02e4b8f50b33d"
+
+PYPI_PACKAGE = "Flask-SQLAlchemy"
+
inherit pypi setuptools3
-require python-flask-sqlalchemy.inc
+
+RDEPENDS_${PN} = "${PYTHON_PN}-sqlalchemy ${PYTHON_PN}-flask"